Cisco Device Management - Lab Exercise

 Cisco Device Management - Lab Exercise


Pada lab ini anda akan mengerjakan factory reset, password recovery, configuration backup, dan system image backup and recovery pada router Cisco. Anda juga akan mengerjakan upgrade IOS pada switch Cisco.

Gunakan Packet Tracer Cisco untuk latihan ini. Server generic pada Packet Tracer sudah built-in dengan TFTP server software.


Lab Topology




Factory Reset



1) View the running configuration on R1. Note that the hostname and interface have been configured

R1#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#exit

R1#

%SYS-5-CONFIG_I: Configured from console by console


R1#show run

Building configuration...


Current configuration : 698 bytes

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname R1

!

!

!

!

!

!

!

!

ip cef

no ipv6 cef

!

!

!

!

license udi pid CISCO2911/K9 sn FTX152447Z1

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface GigabitEthernet0/0

 ip address 10.10.10.1 255.255.255.0

 duplex auto

 speed auto

 no shutdown

!

interface GigabitEthernet0/1

 no ip address

 duplex auto

 speed auto

 shutdown

!

interface GigabitEthernet0/2

 no ip address

 duplex auto

 speed auto

 shutdown

!

interface Vlan1

 no ip address

 shutdown

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

 login

!

!

!

end


2) Factory reset R1 and reboot

R1#write erase

Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]

[OK]

Erase of nvram: complete

%SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram

R1#reload

System configuration has been modified. Save? [yes/no]:no

Proceed with reload? [confirm]

System Bootstrap, Version 15.1(4)M4, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 2010 by cisco Systems, Inc.

Total memory size = 512 MB - On-board = 512 MB, DIMM0 = 0 MB

CISCO2911/K9 platform with 524288 Kbytes of main memory

Main memory is configured to 72/-1(On-board/DIMM0) bit mode with ECC disabled


3) Watch the boot up process as the router boots

Readonly ROMMON initialized


program load complete, entry point: 0x80803000, size: 0x1b340

program load complete, entry point: 0x80803000, size: 0x1b340


IOS Image Load Test

___________________

Digitally Signed Release Software

program load complete, entry point: 0x81000000, size: 0x3bcd3d8

Self decompressing the image :

########################################################################## [OK]

Smart Init is enabled

smart init is sizing iomem

                  TYPE      MEMORY_REQ

     Onboard devices &

          buffer pools      0x022F6000

-----------------------------------------------

                TOTAL:      0x022F6000

Rounded IOMEM up to: 36Mb.

Using 6 percent iomem. [36Mb/512Mb]


              Restricted Rights Legend


Use, duplication, or disclosure by the Government is

subject to restrictions as set forth in subparagraph

(c) of the Commercial Computer Software - Restricted

Rights clause at FAR sec. 52.227-19 and subparagraph

(c) (1) (ii) of the Rights in Technical Data and Computer

Software clause at DFARS sec. 252.227-7013.


           cisco Systems, Inc.

           170 West Tasman Drive

           San Jose, California 95134-1706


Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.1(4)M5, RELEASE SOFTWARE (fc2)Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Wed 18-Jul-07 04:52 by pt_team

Image text-base: 0x2100F918, data-base: 0x24729040


This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.


A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html


If you require further assistance please contact us by sending email to

export@cisco.com.


Cisco CISCO2911/K9 (revision 1.0) with 491520K/32768K bytes of memory.

Processor board ID FTX152400KS

3 Gigabit Ethernet interfaces

DRAM configuration is 64 bits wide with parity disabled.

255K bytes of non-volatile configuration memory.

249856K bytes of ATA System CompactFlash 0 (Read/Write)


4) The router should boot into the Setup Wizard. Exit out of the wizard and then confirm the startup and running configurations are empty.

Router>en

Router#show run

Building configuration...


Current configuration : 693 bytes

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

no ip cef

no ipv6 cef

!

!

!

!

license udi pid CISCO2911/K9 sn FTX152447Z1

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface GigabitEthernet0/0

 no ip address

 duplex auto

 speed auto

 shutdown

!

interface GigabitEthernet0/1

 no ip address

 duplex auto

 speed auto

 shutdown

!

interface GigabitEthernet0/2

 no ip address

 duplex auto

 speed auto

 shutdown

!

interface Vlan1

 no ip address

 shutdown

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

 login

!

!

!

end


5) Paste the configuration for R1 from answer number 1 back into the configuration and save

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname R1

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#ip cef

R1(config)#no ipv6 cef

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#license udi pid CISCO2911/K9 sn FTX152447Z1

                   ^

% Invalid input detected at '^' marker.

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#spanning-tree mode pvst

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#interface GigabitEthernet0/0

R1(config-if)# ip address 10.10.10.1 255.255.255.0

R1(config-if)# duplex auto

R1(config-if)# speed auto

R1(config-if)# no shutdown

R1(config-if)#!

R1(config-if)#interface GigabitEthernet0/1

R1(config-if)# no ip address

R1(config-if)# duplex auto

R1(config-if)# speed auto

R1(config-if)# shutdown

R1(config-if)#!

R1(config-if)#interface GigabitEthernet0/2

R1(config-if)# no ip address

R1(config-if)# duplex auto

R1(config-if)# speed auto

R1(config-if)# shutdown

R1(config-if)#!

R1(config-if)#interface Vlan1

R1(config-if)# no ip address

R1(config-if)# shutdown

R1(config-if)#!

R1(config-if)#ip classless

                 ^

% Invalid input detected at '^' marker.

R1(config-if)#!

R1(config-if)#ip flow-export version 9

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#!

R1(config)#line con 0

R1(config-line)#!

R1(config-line)#line aux 0

R1(config-line)#!

R1(config-line)#line vty 0 4

R1(config-line)# login

% Login disabled on line 388, until 'password' is set

% Login disabled on line 389, until 'password' is set

% Login disabled on line 390, until 'password' is set

% Login disabled on line 391, until 'password' is set

% Login disabled on line 392, until 'password' is set

R1(config-line)#!

R1(config-line)#!

R1(config-line)#!

R1(config-line)#end



Password Recovery



6) Set the enable secret ‘Flackbox1’ on R1

R1(config)#enable secret Flackbox1


7) Configure the router to boot into the rommon prompt on next reload, and reboot the router. In a real world scenario you would enter the Break sequence on the keyboard when first powering up the router to access the rommon prompt

R1(config)#config-register 0x2120

R1(config)#end

R1#

%SYS-5-CONFIG_I: Configured from console by console


R1#cop

R1#copy ru

R1#copy run s

R1#copy run start

Destination filename [startup-config]?

Building configuration...

[OK]

R1#reload

Proceed with reload? [confirm]

System Bootstrap, Version 15.1(4)M4, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 2010 by cisco Systems, Inc.

Total memory size = 512 MB - On-board = 512 MB, DIMM0 = 0 MB

CISCO2911/K9 platform with 524288 Kbytes of main memory

Main memory is configured to 72/-1(On-board/DIMM0) bit mode with ECC disabled


Readonly ROMMON initialized


rommon 1 >


CONFIG REGISTER CONCEPT

EARLY WARNING: JANGAN MAEN2 DISINI KLO GA NGERTI (ngerusakin router nanti ente)

Pengaturan konfig register ini akan menentukan langkah router ketika pertama kali booting up

Kita bisa cek dulu…apa yang dilakukan secara default oleh router pas booting up dengan command “confreg”

Config-register = semacam konfig “bios” komputer ala cisco…mau booting normal, ke tftp server, atau ke safe mode (di cisco namanya Rommon)

Default config-register adalah 0x2102

Artinya itu 0x2102 adalah boot normal (klo normal pasti ga masuk rommon yang pake “break” kan?)

https://belajarcomputernetwork.files.wordpress.com/2017/02/020317_1027_managingcis33.png?w=500

8) Configure the router to ignore the startup-config when booting up, and reload the router

Readonly ROMMON initialized


rommon 1 > confreg 0x2142

rommon 2 > reset

System Bootstrap, Version 15.1(4)M4, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 2010 by cisco Systems, Inc.

Total memory size = 512 MB - On-board = 512 MB, DIMM0 = 0 MB

CISCO2911/K9 platform with 524288 Kbytes of main memory

Main memory is configured to 72/-1(On-board/DIMM0) bit mode with ECC disabled


Readonly ROMMON initialized


program load complete, entry point: 0x80803000, size: 0x1b340

program load complete, entry point: 0x80803000, size: 0x1b340


IOS Image Load Test

___________________

Digitally Signed Release Software

program load complete, entry point: 0x81000000, size: 0x3bcd3d8

Self decompressing the image :

########################################################################## [OK]

Smart Init is enabled

smart init is sizing iomem

                  TYPE      MEMORY_REQ

     Onboard devices &

          buffer pools      0x022F6000

-----------------------------------------------

                TOTAL:      0x022F6000

Rounded IOMEM up to: 36Mb.

Using 6 percent iomem. [36Mb/512Mb]


              Restricted Rights Legend


Use, duplication, or disclosure by the Government is

subject to restrictions as set forth in subparagraph

(c) of the Commercial Computer Software - Restricted

Rights clause at FAR sec. 52.227-19 and subparagraph

(c) (1) (ii) of the Rights in Technical Data and Computer

Software clause at DFARS sec. 252.227-7013.


           cisco Systems, Inc.

           170 West Tasman Drive

           San Jose, California 95134-1706


Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.1(4)M5, RELEASE SOFTWARE (fc2)Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Wed 18-Jul-07 04:52 by pt_team

Image text-base: 0x2100F918, data-base: 0x24729040


This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.


A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html


If you require further assistance please contact us by sending email to

export@cisco.com.


Cisco CISCO2911/K9 (revision 1.0) with 491520K/32768K bytes of memory.

Processor board ID FTX152400KS

3 Gigabit Ethernet interfaces

DRAM configuration is 64 bits wide with parity disabled.

255K bytes of non-volatile configuration memory.

249856K bytes of ATA System CompactFlash 0 (Read/Write)



         --- System Configuration Dialog ---


Would you like to enter the initial configuration dialog? [yes/no]:


Yang biasa dipake selain 0x2102 adalah 0x2142: angka 4 (bit ke 6) artinya IGNORE NVRAM

Biasanya klo mau reset password, confreg-nya dirubah pake kode ini, cek how to reset password

Jadi klo ada salah2 (kek harusnya ngetik 2142 jadi 2124, trus malah jadi ga bisa masuk…cek itu “42” dan “24”….biasanya BAUD rate-nya yg bikin console terminal kita ga kebaca)

Bisa di cek di cisco.com untuk config register-nya

Ganti config register ada 2 cara…dari rommon (commandnya confreg 0xXXXX) atau dari global config

https://belajarcomputernetwork.files.wordpress.com/2017/02/020317_1027_managingcis34.png?w=500

Kita liat di show version di yang paling bawah…harus di reload dulu



9) The router should boot into the Setup Wizard. Exit out of the wizard

         --- System Configuration Dialog ---


Would you like to enter the initial configuration dialog? [yes/no]: no



Press RETURN to get started!




Router>


10) What do you expect to see if you view the running and startup configurations? Confirm this.

Run-Start config akan kembali ke factory reset karena router melewatkan loading startup config saat boot up. Startup config seharusnya tidak berubah dan konfigurasi sebelumnya masih ada disana.

Router#sh run

Building configuration...

!

hostname Router

!

interface GigabitEthernet0/0

 no ip address

 duplex auto

 speed auto

 shutdown


Router#show start

Using 757 bytes

!

hostname R1

!

enable secret 5 $1$mERr$J2XZHMOgpVVXdLjC9lYtE1

!

interface GigabitEthernet0/0

 ip address 10.10.10.1 255.255.255.0

 duplex auto

 speed auto

 no shutdown


11) Copy the startup config to the running config. Do not miss this step or you will factory reset the router!

Router#copy startup-config running-config 

Destination filename [running-config]? 


757 bytes copied in 0.416 secs (1819 bytes/sec)

R1#


12) Remove the enable secret

R1(config)#no enable secret


13) Ensure the router will reboot normally on the next reload and you will be able to access the router

R1(config)#config-register 0x2102

R1(config)#end

R1#

%SYS-5-CONFIG_I: Configured from console by console


R1#copy ru

R1#copy running-config st

R1#copy running-config startup-config 

Destination filename [startup-config]? 

Building configuration...

[OK]

R1#


14) Reboot the router to confirm

R1#reload

Proceed with reload? [confirm]

System Bootstrap, Version 15.1(4)M4, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 2010 by cisco Systems, Inc.

Total memory size = 512 MB - On-board = 512 MB, DIMM0 = 0 MB

CISCO2911/K9 platform with 524288 Kbytes of main memory

Main memory is configured to 72/-1(On-board/DIMM0) bit mode with ECC disabled


Readonly ROMMON initialized


program load complete, entry point: 0x80803000, size: 0x1b340

program load complete, entry point: 0x80803000, size: 0x1b340


IOS Image Load Test

___________________

Digitally Signed Release Software

program load complete, entry point: 0x81000000, size: 0x3bcd3d8

Self decompressing the image :

########################################################################## [OK]

Smart Init is enabled

smart init is sizing iomem

                  TYPE      MEMORY_REQ

     Onboard devices &

          buffer pools      0x022F6000

-----------------------------------------------

                TOTAL:      0x022F6000

Rounded IOMEM up to: 36Mb.

Using 6 percent iomem. [36Mb/512Mb]


              Restricted Rights Legend


Use, duplication, or disclosure by the Government is

subject to restrictions as set forth in subparagraph

(c) of the Commercial Computer Software - Restricted

Rights clause at FAR sec. 52.227-19 and subparagraph

(c) (1) (ii) of the Rights in Technical Data and Computer

Software clause at DFARS sec. 252.227-7013.


           cisco Systems, Inc.

           170 West Tasman Drive

           San Jose, California 95134-1706


Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.1(4)M5, RELEASE SOFTWARE (fc2)Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Wed 18-Jul-07 04:52 by pt_team

Image text-base: 0x2100F918, data-base: 0x24729040


This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.


A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html


If you require further assistance please contact us by sending email to

export@cisco.com.


Cisco CISCO2911/K9 (revision 1.0) with 491520K/32768K bytes of memory.

Processor board ID FTX152400KS

3 Gigabit Ethernet interfaces

DRAM configuration is 64 bits wide with parity disabled.

255K bytes of non-volatile configuration memory.

249856K bytes of ATA System CompactFlash 0 (Read/Write)


Press RETURN to get started!




R1>

R1#show run

!

hostname R1

!

interface GigabitEthernet0/0

 ip address 10.10.10.1 255.255.255.0

 duplex auto

 speed auto

 no shutdown


Configuration Backup



15) Backup the running configuration to Flash on R1. Use a suitable name for the backup file. Verify the configuration has been backed up.

R1#copy run flash: 

Destination filename [running-config]? 

Building configuration...

[OK]

R1#show flash


System flash directory:

File  Length   Name/status

  3   33591768 c2900-universalk9-mz.SPA.151-4.M4.bin

  4   696      demo

  5   698      running-config

  2   28282    sigdef-category.xml

  1   227537   sigdef-default.xml

[33848981 bytes used, 221895019 available, 255744000 total]

249856K bytes of processor board System flash (Read/Write)


16) Backup the R1 startup configuration to the TFTP server. Use a suitable name for the backup file. Verify the configuration has been backed up.

R1#copy running-config tftp

Address or name of remote host []? 10.10.10.10

Destination filename [R1-confg]? 


Writing running-config....!!

[OK - 698 bytes]


698 bytes copied in 3.072 secs (227 bytes/sec)

R1#



IOS System Image Backup and Recovery



17) Backup the IOS system image on R1 to the TFTP server. Verify the configuration has been backed up.

R1#show flash


System flash directory:

File  Length   Name/status

  3   33591768 c2900-universalk9-mz.SPA.151-4.M4.bin

  4   696      demo

  5   698      running-config

  2   28282    sigdef-category.xml

  1   227537   sigdef-default.xml

[33848981 bytes used, 221895019 available, 255744000 total]

249856K bytes of processor board System flash (Read/Write)



R1#copy flash tf

R1#copy flash tftp: 

Source filename []? c2900-universalk9-mz.SPA.151-4.M4.bin

Address or name of remote host []? 10.10.10.10

Destination filename [c2900-universalk9-mz.SPA.151-4.M4.bin]? 


Writing c2900-universalk9-mz.SPA.151-4.M4.bin...!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

[OK - 33591768 bytes]


33591768 bytes copied in 1.052 secs (3352658 bytes/sec)

R1#


18) Delete the system image from Flash and reload.

R1#delete flash

Delete filename []?c2900-universalk9-mz.SPA.151-4.M4.bin

Delete flash:/c2900-universalk9-mz.SPA.151-4.M4.bin? [confirm]


R1#show flash


System flash directory:

File  Length   Name/status

  4   696      demo

  5   698      running-config

  2   28282    sigdef-category.xml

  1   227537   sigdef-default.xml

[257213 bytes used, 255486787 available, 255744000 total]

249856K bytes of processor board System flash (Read/Write)



R1#reload

Proceed with reload? [confirm]

System Bootstrap, Version 15.1(4)M4, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 2010 by cisco Systems, Inc.

Total memory size = 512 MB - On-board = 512 MB, DIMM0 = 0 MB

CISCO2911/K9 platform with 524288 Kbytes of main memory

Main memory is configured to 72/-1(On-board/DIMM0) bit mode with ECC disabled


Readonly ROMMON initialized


Boot process failed...


The system is unable to boot automatically.  The BOOT

environment variable needs to be set to a bootable

image.

rommon 1 >


19) Use Internet search to find system recovery instructions for your model of router. Recover the system image using the TFTP server.

https://www.cisco.com/c/en/us/td/docs/routers/access/1900/software/configuration/guide/Software_Configuration/appendixCrommon.html

Buka webpage tersebut lalu cari section tftpdnld. Lalu pada R1 input command-command berikut.

rommon 16 > IP_ADDRESS=10.10.10.1

rommon 17 > IP_SUBNET_MASK=255.255.255.0

rommon 18 > DEFAULT_GATEWAY=10.10.10.1

rommon 19 > TFTP_SERVER=10.10.10.10

rommon 20 > TFTP_FILE=c2900-universalk9-mz.SPA.151-4.M4.bin


Cabut koneksi router dan tftp ke switch. Sambungkan langsung router dan tftp hingga proses download system image selesai.



rommon 21 > tftpdnld

 

IP_ADDRESS: 10.10.10.1

IP_SUBNET_MASK: 255.255.255.0

DEFAULT_GATEWAY: 10.10.10.1

TFTP_SERVER: 10.10.10.10

TFTP_FILE: c2900-universalk9-mz.SPA.151-4.M4.bin

 

Invoke this command for disaster recovery only.

WARNING: all existing data in all partitions on flash will be lost!

Do you wish to continue? y/n: [n]: y

 

Receiving c2900-universalk9-mz.SPA.151-4.M4.bin from 10.10.10.10 !!!!!!!!!!!!!!!!!!!!!!!!!!

File reception completed.

Copying file c2900-universalk9-mz.SPA.151-4.M4.bin to flash.

Erasing flash at 0x607c0000

program flash location 0x60440000

rommon 22 > reset


System Bootstrap, Version 15.1(4)M4, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 2010 by cisco Systems, Inc.

Total memory size = 512 MB - On-board = 512 MB, DIMM0 = 0 MB

CISCO2911/K9 platform with 524288 Kbytes of main memory

Main memory is configured to 72/-1(On-board/DIMM0) bit mode with ECC disabled


Readonly ROMMON initialized


program load complete, entry point: 0x80803000, size: 0x1b340

program load complete, entry point: 0x80803000, size: 0x1b340


IOS Image Load Test

___________________

Digitally Signed Release Software

program load complete, entry point: 0x81000000, size: 0x3bcd3d8

Self decompressing the image :

########################################################################## [OK]

Cisco CISCO2911/K9 (revision 1.0) with 491520K/32768K bytes of memory.

Processor board ID FTX152400KS

3 Gigabit Ethernet interfaces

DRAM configuration is 64 bits wide with parity disabled.

255K bytes of non-volatile configuration memory.

249856K bytes of ATA System CompactFlash 0 (Read/Write)


Press RETURN to get started!




R1>



IOS Image Upgrade



21) Verify SW1 is running C2960 Software (C2960-LANBASE-M), Version 12.2(25)FX

SW1#show version

Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(25)FX, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2005 by Cisco Systems, Inc.

Compiled Wed 12-Oct-05 22:05 by pt_team


ROM: C2960 Boot Loader (C2960-HBOOT-M) Version 12.2(25r)FX, RELEASE SOFTWARE (fc4)


System returned to ROM by power-on


Cisco WS-C2960-24TT (RC32300) processor (revision C0) with 21039K bytes of memory.



24 FastEthernet/IEEE 802.3 interface(s)

2 Gigabit Ethernet/IEEE 802.3 interface(s)


63488K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address       : 0030.F2E1.CDDB

Motherboard assembly number     : 73-9832-06

Power supply part number        : 341-0097-02

Motherboard serial number       : FOC103248MJ

Power supply serial number      : DCA102133JA

Model revision number           : B0

Motherboard revision number     : C0

Model number                    : WS-C2960-24TT

System serial number            : FOC1033Z1EY

Top Assembly Part Number        : 800-26671-02

Top Assembly Revision Number    : B0

Version ID                      : V02

CLEI Code Number                : COM3K00BRA

Hardware Board Revision Number  : 0x01



Switch   Ports  Model              SW Version              SW Image

------   -----  -----              ----------              ----------

*    1   26     WS-C2960-24TT      12.2                    C2960-LANBASE-M


Configuration register is 0xF


22) Use the TFTP server to upgrade to C2960-lanbasek9-mz.150-2.SE4.bin

SW1#copy tftp flash 

Address or name of remote host []? 10.10.10.10

Source filename []? c2960-lanbasek9-mz.150-2.SE4.bin

Destination filename [c2960-lanbasek9-mz.150-2.SE4.bin]? 


Accessing tftp://10.10.10.10/c2960-lanbasek9-mz.150-2.SE4.bin....

Loading c2960-lanbasek9-mz.150-2.SE4.bin from 10.10.10.10: !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

[OK - 4670455 bytes]


4670455 bytes copied in 3.062 secs (122628 bytes/sec)

SW1#show flash

Directory of flash:/


    1  -rw-     4414921          <no date>  c2960-lanbase-mz.122-25.FX.bin

    3  -rw-     4670455          <no date>  c2960-lanbasek9-mz.150-2.SE4.bin

    2  -rw-        1054          <no date>  config.text


64016384 bytes total (54929954 bytes free)

SW1#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

SW1(config)#boot system c2960-lanbasek9-mz.150-2.SE4.bin


23) Reboot and verify the switch is running the new software version

SW1#reload

System configuration has been modified. Save? [yes/no]:yes

Building configuration...

[OK]

Proceed with reload? [confirm]

C2960 Boot Loader (C2960-HBOOT-M) Version 12.2(25r)FX, RELEASE SOFTWARE (fc4)

Cisco WS-C2960-24TT (RC32300) processor (revision C0) with 21039K bytes of memory.

2960-24TT starting...

Base ethernet MAC Address: 0030.F2E1.CDDB

Xmodem file system is available.

Initializing Flash...

flashfs[0]: 3 files, 0 directories

flashfs[0]: 0 orphaned files, 0 orphaned directories

flashfs[0]: Total bytes: 64016384

flashfs[0]: Bytes used: 9086465

flashfs[0]: Bytes available: 54929919

flashfs[0]: flashfs fsck took 1 seconds.

...done Initializing Flash.


Boot Sector Filesystem (bs:) installed, fsid: 3

Parameter Block Filesystem (pb:) installed, fsid: 4



Loading "flash:/c2960-lanbasek9-mz.150-2.SE4.bin"...

########################################################################## [OK]

Smart Init is enabled

smart init is sizing iomem

                  TYPE      MEMORY_REQ

                TOTAL:      0x00000000

Rounded IOMEM up to: 0Mb.

Using 6 percent iomem. [0Mb/512Mb]


              Restricted Rights Legend

Use, duplication, or disclosure by the Government is

subject to restrictions as set forth in subparagraph

(c) of the Commercial Computer Software - Restricted

Rights clause at FAR sec. 52.227-19 and subparagraph

(c) (1) (ii) of the Rights in Technical Data and Computer

Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.

           170 West Tasman Drive

           San Jose, California 95134-1706

Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 15.0(2)SE4, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2013 by Cisco Systems, Inc.

Compiled Wed 26-Jun-13 02:49 by mnguyen

Initializing flashfs...

fsck: Disable shadow buffering due to heap fragmentation.

flashfs[2]: 2 files, 1 directories

flashfs[2]: 0 orphaned files, 0 orphaned directories

flashfs[2]: Total bytes: 32514048

flashfs[2]: Bytes used: 11952128

flashfs[2]: Bytes available: 20561920

flashfs[2]: flashfs fsck took 2 seconds.

flashfs[2]: Initialization complete....done Initializing flashfs.

Checking for Bootloader upgrade..

Boot Loader upgrade not required (Stage 2)

POST: CPU MIC register Tests : Begin

POST: CPU MIC register Tests : End, Status Passed

POST: PortASIC Memory Tests : Begin

POST: PortASIC Memory Tests : End, Status Passed

POST: CPU MIC interface Loopback Tests : Begin

POST: CPU MIC interface Loopback Tests : End, Status Passed

POST: PortASIC RingLoopback Tests : Begin

POST: PortASIC RingLoopback Tests : End, Status Passed

POST: PortASIC CAM Subsystem Tests : Begin

POST: PortASIC CAM Subsystem Tests : End, Status Passed

POST: PortASIC Port Loopback Tests : Begin

POST: PortASIC Port Loopback Tests : End, Status Passed

Waiting for Port download...Complete


This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

cisco WS-C2960-24TT-L (PowerPC405) processor (revision B0) with 65536K bytes of memory.

Processor board ID FOC1010X104

Last reset from power-on

1 Virtual Ethernet interface

24 FastEthernet interfaces

2 Gigabit Ethernet interfaces

The password-recovery mechanism is enabled.

64K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address       : 00:17:59:A7:51:80

Motherboard assembly number     : 73-10390-03

Power supply part number        : 341-0097-02

Motherboard serial number       : FOC10093R12

Power supply serial number      : AZS1007032H

Model revision number           : B0

Motherboard revision number     : B0

Model number                    : WS-C2960-24TT-L

System serial number            : FOC1010X104

Top Assembly Part Number        : 800-27221-02

Top Assembly Revision Number    : A0

Version ID                      : V02

CLEI Code Number                : COM3L00BRA

Hardware Board Revision Number  : 0x01


Switch Ports Model              SW Version            SW Image

------ ----- -----              ----------            ----------

*    1 26    WS-C2960-24TT-L    15.0(2)SE4            C2960-LANBASEK9-M


Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 15.0(2)SE4, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2013 by Cisco Systems, Inc.

Compiled Wed 26-Jun-13 02:49 by mnguyen




Press RETURN to get started!




SW1>


Comments

Popular posts from this blog

Configuring OSPF + RIP + EIGRP